This project has moved and is read-only. For the latest updates, please go here.

Issue with installation due to failure to find System.ServiceModel.Activation in GAC

Jan 31, 2013 at 1:41 AM

Sorry if this sounds like a newbie question, I tried googling for a solution but could not find any. I was trying to do a Nuget with the following settings
  1. Visual Studio 2010 Version 10.0.30319.1 RTMRel (Professional)
  2. Microsoft .NET Version 4.5.50709 RTMRel
  3. Unity version 2.1.505
I get a System.ServiceModel.Activation in GAC not registered in GAC error, may I know if anyone knows how to fixed this. Looking at the Nuget config in the source code I think it is listed as one of the Framework dependencies but when I check the GAC that assembly is not found. I think there is a namespace System.ServiceModel.Activation that is found in System.ServiceModel may I know if I am doing something wrong.
Feb 1, 2013 at 1:55 AM
I guess I must have been doing it wrongly, I was doing a Nuget on a WCF library, I guess because that is not the host it cannot reference System.ServiceModel.Activation. I tired Nuget on the WCF application and it worked. Hopefully this might help others who face the same issue
Feb 6, 2013 at 3:22 PM
Glad you sorted it out